Modems FAQ

From OMAPpedia

Jump to: navigation, search

Contents

[edit] General

[edit] I can attach to a cellular network but I can't get a decent signal strength

1. Antenna On TI development platforms like Blaze, ensure that the modem antenna connector is connected to the UMTS Antenna Primary connector with an adapted RF cable. You can also use an external Antenna although you should ensure that it supports the bands for your modem. It is also a good idea to replace the Antenna cable if you have any doubt with it.

2. RF calibration Certain modems may require tuned RF calibration. Ensure with the modem maker that you have the right data and that they are properly installed.

3. Environment Test with a reference phone that the low signal strength is not caused by your environment.


[edit] HSI

[edit] Enable the HSI Kernel trace

1. build the kernel with CONFIG_DYNAMIC_DEBUG=y

2. mount a debug file system on /d/ or /debugfs/ or /debug/

3. type “echo -n 'module omap_hsi +p' > /d/dynamic_debug/control” to enable the trace

4. type “cat /d/dynamic_debug/control | grep hsi” to see only HSI trace

example:

<7>omap_hsi omap_hsi.0: Int Tasklet : clock_enabled=1
<7>omap_hsi omap_hsi.0: CLK: hsi_clocks_enable: do_hsi_tasklet
<7>omap_hsi omap_hsi.0: Clocks already enabled, skipping...
<7>omap_hsi omap_hsi.0: Channels [0,7] : Events 0x00000100
<7>omap_hsi omap_hsi.0: Data Available interrupt for channel 0.
<7>omap_hsi omap_hsi.0: Channels [8,15] : no event, exit.
<7>omap_hsi omap_hsi.0: CLK: hsi_clocks_disable: do_hsi_tasklet
<7>omap_hsi omap_hsi.0: Port 1: WAKE status: acwake_status 1,cur_cawake 1
<7>omap_hsi omap_hsi.0: Port 1 busy
<7>omap_hsi omap_hsi.0: Cannot disable clocks, HSI port busy
<7>omap_hsi omap_hsi.0: Int Tasklet : clock_enabled=1
<7>omap_hsi omap_hsi.0: CLK: hsi_clocks_enable: do_hsi_tasklet

[edit] Audio

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox